xPilot CSL manual download?

Hello everyone I use X-Plane 11 currently. I am new to VATSIM and I have been having problems with the xPilot automatic download of CSL’s. My internet is not great and I have wasted a lot of data trying to restart the CSL automatic download. I downloaded a Bluebell CSL zip and set the path to plugins\xPilot\Resources\CSL in the X-Plane 11 plugin. I am also in the process of downloading X-CSL liveries.

Every time that I start xPilot it asks me to download the CSL. I got fed up with the amount of data that I wasted because there is no resume download function. Is there a way to manually download the original CSL package that xPilot uses manually with a resume download option if my internet crashes?

Hello Chris,

It sounds like you are already familiar with the two options for installing a CSL package. You can have the client automatically download and install the package, or you can manually download the aircraft model set and install it into the Resources folder. I am not aware of a resume feature which downloads only the missing files.

Since you manually downloaded and extracted the Bluebell zip package, the CSL library is ready to go. If you are still seeing the initial message stating “this is the first time using xPilot and you must download a CSL aircraft model set”, check the “Don’t ask me again” box, and click No. xPilot will work correctly,

Just be sure to finish setting up the other necessary items on the xPilot Settings page.

1 Like

Thanks Tim. X-CSL has an index on the default server and it does a check against the files already downloaded and either updates or replaces the files when needed. It would be nice if we could see the default xPilot CSL link and so we can download it manually.

Any chance you could assist me with this problem no matter what folder (trust me I have tried every folder in xplane and on my computer) and no matter what file folder I try to save my xpilot CSL files, it rejects saving due to not being an acceptable folder. See my screenshot in link. Message may change slightly depending on folder I am trying to save too, but generally it won’t save for the same reason. So frustrating. I am running a newer iMac 24 M1 chip. I run xplane 11 and 12 essentially and have very limited issues with my Mac running these programs. Thanks for any assistance!

I don’t have a Mac, so I can’t test the issue you are seeing. My only guess would be that you are experiencing a security/privacy issue related to disk and folder access. Does the xPilot app have disk access and access to the appropriate files and folders?