xPilot ATC frequency issue

Hello, I try to tune into a frequency on xplane 12. I insert the frequency in my airplane and set it to the active frequency however in xpilot it doesnt tune to that frequency and when i press “tune to COM1 Radio” It switches for half a second and then automatically switches back to another frequency.

I think MSFS2020/Xplane has some autotune capabilities, you’ll need to disengage.

That is the ATC Auto-tune feature of X-Plane 12.

Take a quick look at this previous post:

The Auto-tune “feature” of X-Plane that Tim pointed out is the cause for most of these problems.

But as you describe it (you are able to set COM1 in the plane to the desired frequency but xPilot does not register it) it could be something with the plane. Which plane are you using?

Ya. I was having the same issue. What solved it was looking at the first officer radio frequencies and changing them. If the FO radio was set to VHF1 and it’s ex. 124.35, then anytime I tried to set my PIC radio to something else (VHF1), it jumps right back to 124.35. May work to change the FO’s radio frequencies in your virtual a/c. Good luck!

Hi, I have the same problem, no matter what aircraft I used with XP 12. It doesn’t do that with XP11. There’s must be a solution for this. Itt would be interesting to know if other pilots flying on Vatsim have the same problem.

Look at the normal COM1/COM2 DataRefs if you can.
If the aircraft reads and sets them correctly xPilot will reflect exactly that.

Which aircrafts have you tried exactly? What are the messages you see in the xPilot app? (Does it say “connected to X-Plane”?). Please, we need more and better info to help with your problems.