X-pilot can no longer change com frequencies

I am running x-plane 12.07 on a Macbook M2 with x-pilot as my Vatsim client which used to work fine with Vatsim. Now x-pilot cannot change com frequencies. They just switch back to frequencies x-plane selected. “Autotune ATC frequencies” is turned off in x-plane ATC settings which used to the fix for this problem. I also cannot manually change the frequencies. They just switch back. So I can’t fly Vatsim. Others must have this problem.

The problem resolved itself after I ran the installer which found nothing new to install, but seems to have fixed the problem. Every time I would start a flight the ATC ground services dialog would pop up which no longer happens.