vPilot "Your simulator seems to be Frozen"

Greetings everyone. This is my last ditch effort at trying to get some guidance with an issue I’m having with vPilot. For the last 2-3 weeks every flight I do (MSFS 2020) at least 3-4 times per flight vPilot will disconnect me from the network and hit me with the “Your simulator appears to be frozen” error. My simulator, however, is running smoothly and in fact is not frozen (no stutters either).

I’ve tried using the .debug command to view the debug messages, but if I’m not connected, nothing populates there. Can’t find any log files either.

Things I’ve tried already: Reinstalling vPilot, running as admin, not running as admin…but all have been unsuccessful. All drivers are up to date, vPilot is up to date (3.6.0 at the time of this post).

Has anyone else experienced this issue? I’ve been an active controller/pilot on VATSIM since early 2007, and I (think) I’ve exhausted my efforts in trying to find the issue.

Thanks for any help in advance!

From the debug:


Alright - I think I found the culprit after going deep into some MSFS log files through some logging software I found deep on the internet (lol). I had installed “Your Controls” a few weeks ago to do some shared cockpit flying… turns out it was getting hung on something and in the log file found that it was causing a hung call through simconnect that I guess vPilot didn’t like?

Just completed a 1.5hr flight and experienced no issues after removing Your Controls. Will bump this should the issue arise again.