vPilot won't minimize via shortcut

Hi, I am trying to use windows shortcuts to minimize vPilot. For example, when vPilot is the first window on the taskbar, I am trying to use “Win logo key + 1”. This works for other windows and software. I.e.; if chrome is the first window, pressing “Win logo key + 1” minimizes it. A second press brings it back into focus.

My goal is to create stream deck shortcuts that will minimize/focus frequently used software during a flight. However vPilot doesn’t seem to have this capability. Also, when I “shift + R-click” vPilot’s taskbar button, the menu options for minimize and maximize do not show up like other programs. Actually no menu shows up for vPilot. This leads me to believe it’s coded this way perhaps. I have tried unchecking “keep window visible” under Settings>Miscellaneous. That changes nothing.

I’ve been researching alternate methods like using a powershell script but have not been successful.

Is this some that would be easy to code into the program?


This is an unfortunate side effect of the fact that vPilot doesn’t have a normal title bar and control menu. It’s unlikely to be changed.

Thanks Ross. I was afraid of that. -Vin

Look for an extension called “Window Actions” for the Stream Deck. It’s on the official Store.
Works like a charm :slight_smile: