vPilot won't map PTT on Redbird

I can’t get vPilot to map my PTT on Redbird sim. I’ve tried run as administrator, and from a dozen different ways. But vPilot just won’t map the PTT. What is the trick? Thank you

I think Redbird PTTs don’t appear as a regular joystick/yoke button, so they aren’t recognized by vPilot. I think they use their own custom software driver to recognize the button. I’m not 100% sure about this, but I believe that was the case years ago when I did some work with Redbird sims.

1 Like

Thanks for responding. So VATSIM won’t work for Redbird? I’ve been using Pilot Edge which had an almost identical setup as vPilot and works great with Pilot Edge.


The PE client has some special Redbird integration that vPilot doesn’t have.

Tried to map PTT for several hours with every possible combination with no luck.

Any possibility for vPilot future versions to allow Redbird users to also use VATSIM?
Thank you,

I’ve added it to the wishlist.

This has been implemented and will be available in the next release, which should be at the beginning of March.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.