vPilot software won't startup

So I’m trying to get back onto vatsim after many years away. I’ve downloaded the required vPilot software, running MSFS, and followed all the install directions, run as admininstrator, checked all my .net framework software up to date. I checked “to allow all desktop apps” to use the microphone (however, I don’t see vPilot on any list in the microphone list to give it special permission (running win10 home)). My headset microphone works when testing it through windows. I’ve tried uninstalling, reinstalling, running as admin, installing as admin, but nothing works. As soon as I click on the desktop shortcut to open, it immediately gives a unhandled exception error and I can’t do anything. I’ve seen in the forum history where others have reported this issue but I’ve tried all the suggestions and it still won’t work. Maybe it’s something simple I’m missing, but I’m out of things to try. Anyone’s help would be greatly appreciated. Here’s screenshot of the unhandled exception error.


I can’t see the full exception, but it sure appears to be related to audio. FYI, copying and pasting the actual exception text is far more useful than a screenshot.

A couple questions:

  1. Have you installed the most recent audio drivers available for your specific motherboard?

  2. You said “my .net framework software up to date”. But…what runtime?? There are several different versions, and vPilot uses an older one: 4.7.2