vPilot and FS2020, audio lags and stutters unless process priority is manually increased

Hello all,
I’m running vPilot version 3.4.7 on my Windows 11 PC.
The software is working as expected for me when using Prepar3D as the simulator, without any audio or performance issues whatsoever.
Recently I began using Microsoft Flight Simulator 2020 which puts about 50% load on my CPU, so there’s plenty of headroom for other processing tasks.
However, I am consistently having an issue where ATC audio coming from vPilot sounds extremely choppy, this only occurs when the vPilot window is in the background, issue does not reproduce when vPilot is the active window.

I have tried several things to mitigate this, which included selecting a different audio output device, switching to a different VATSIM server, testing at different airports and reducing FS2020’s graphics settings to lighten CPU and GPU load, I’ve also reinstalled vPilot completely.
vPilot is always running with admin privileges on my system, and I’m using an ethernet connection to my router which in turn is connected to the internet using a 400MBpS down / 100MBpSup cable connection.
I did find a workaround to solve the issue, and this is to open Task Manager, find the vPilot.exe process and increase its process priority to high, which again results in pristine, stutter-free audio.

This is also not a temporary glitch as far as I can tell, it’s been going on for over a week now and makes vPilot pretty much unusable unless I manually go in and raise the priority.
As this is of course far from perfect, I was wondering if the issue I described is a known bug and whether there might be better solutions to address this?

Any help would be greatly appreciated, also happy to provide any additional details if needed.


It sounds like your processor is struggling with background tasks while playing MSFS. You have already found a way to fix this by setting a process affinity with task manager.

Apart from that, you might want to look into upgrading your computer. What CPU do you have?

Also, assuming you are using Windows, look into turning off Gaming Mode which sets background tasks to a lower priority while playing games.

Hey Ryan,

Thanks for the response.
My processor is an AMD Ryzen 7 5800X 8-Core Processor, 3.80 GHz.
Not sure if it’s really struggling with background processes, as CPU load only goes up to around 50% while the sim is running, and even if I start playing a video in the background that runs smoothly as well.
I’ve also tried disabling game mode, however that made no difference sadly.
Any other suggestions of things I could try?


Sorry for the delay. Your CPU is definitely good enough to run MSFS. Have you checked whether you are running into a thermal throttle while playing?

It shouldn’t be struggling with that CPU at all. I’d check and see what temps you are getting, whether you’re being downclocked, etc.

Hey Ryan,

Thanks so much for all your suggestions.
I was able to find what the problem was, this wasn’t actually vPilot’s fault.
I’m currently using a beta version of Talking Flight Monitor, which is an add-on tool that I use with the sim as a blind pilot. Turns out this is currently eating up a lot more CPU cycles than it would need, causing the stuttering issues. The stuttering stops as soon as I quit TFM, and TFM’s developers are now looking into the issue.

Thanks again for the help!

Glad you got this resolved. Happy flying!