Trouble connecting to xpilot network

I cant connect to the xpilot network. i followed the steps for the fire wall. im running the program through steam, could that be the issue?

You mean the VATSIM network. xpilot is one of several pilot clients used to connect to VATSIM.

The problem here is xpilot can’t identify that X-Plane is running. Try a clean install of xpilot. If that still doesn’t work, the forum would be better placed to troubleshoot.

I tried both but it still wont work. i think the problem may be that i cant install the CSL aircraft model set

Your immediate problem is not the CSL models. The xPilot application needs a plugin installed inside X-Plane. The installer should do that for you but maybe it failed or is misconfigured.
Running xPilot under Steam is fine. You just need to make sure to use the correct path to X-Plane under Steam in the installer.

When following Installation | xPilot for VATSIM, do you see the xPilot plugin in X-Plane’s menu?

After that, see this point in the FAQ: FAQ | xPilot for VATSIM

For more help you should include much more information.