Swift GUI not launching

I just installed swift, and im planning to join VATSIM with FlightGear. when i start Swift GUI the blue circle thing appear with a barely readable message but after that no response from the swift side and SwiftGUI does not pop up on the screen or task manager. pls help.I tried reinstalling swift, launching with admin already but no success please help.


Sorry that you are experiencing difficulties. Did you follow our installation procedure for swift with FlightGear? What version of swift are you using? We recommend using the latest ALPHA (they are stable). At the time of writing this would be version 0.12.111 .


Yes, i have tried to but to no avail. I have tried to install 32bit, 64bit, do a clean install, just nothing happens. it just pops up for 2 seconds, it now says the version number but nothing pops up, and the thing just never launches. i have went through that document, and tried like 10 other tutorial on youtube but every time it refuse to work

Also is has this log when on swiftcore

We are now in contact in our Discord server.