Strange error while launching freshly installed latest version of Xpilot

Hi there.
I just tried to go for a flight in X-Plane 11 using Xpilot. When I launched the Xpilot client and tried to connect to voice server, I got the message that the client version is outdated. Then I updated the client as Xpilot app suggested, and on the first launch got this error:
After that Xpilot didn’t launch at all. Same happened when I downloaded a fresh .exe installer from the official Xpilot’s Github page and the same happened. I’m speaking of xPilot v2.0.0 beta 49 Releases · xpilot-project/xpilot · GitHub.

The error is caused by obsolete app dependencies from previous versions not getting deleted by the installer, thus causing xPilot to crash when trying to launch it after updating.

The simplest solution is to delete the entire folder where the xPilot client is installed (by default, C:\Program Files\xPilot ), then re-run the latest xPilot installer.

Thanks Justin, fixed by deleting the xPilot folder from Program Files folder. I was just surprised by so strange and scary error name :slight_smile: