Robotic mic on Vpilot

Hear ATC just fine but my mic is coming out robotic on Vpilot. Tried uninstalling and reinstalling vpilot, updated my drivers, running the program as admin, setting the priority in task manager etc. Tested the mic in windows control panel and it works fine and sounded fine with Xpilot as well. Any suggestions on a fix?
I think another user had this issue as well, here’s a video of it below