No flight plan filed even when I was told the opposite using the Prefile feature in SimBrief for Vatsim

As the topic suggests, I just prefiled a FP via SimBrief like I always do. Received the message how the flight plan was filed successfully and how I should enjoy my flight.

However, when talking to ATC, I was informed a FP had not been filed. I could confirm this myself when using the ‘Fetch FP’ button in vPilot. Which usually works just fine. This time, I was told the same thing ATC just told me, no flight plan was found on the server. Despite having been told the opposite using the prefile feature.

Anyone else had this issue?

Today it was back to normal. So must have been some temp issue yesterday.

Now I’m having the same issue again and it’s quite frustrating since this means I have to put in everything manually in vPilot.

Surely I can’t be the only one who’ve seen this issue?

Personally, I don’t see that issue because I always use vPilot to file, as it’s 100% reliable. Simbrief may be 99%, or 98%, not sure what the reliability level is, though I don’t recall hearing issues other than this thread, and there are thousands of flight plans filed on VATSIM daily (though not sure how many via Simbrief).

When you say you prefile through SimBrief, Richard, doesn’t that simply take you to VATSIM’s flight plan page and auto-populate all of the info there? The only troubleshooting tip I can think of is double-checking that you’re logging onto the network with the same exact callsign that you’re filing through SimBrief/VATSIM’s FP page.

I do miss being able to file through the pilot clients, Don. It reminded me of the old FAA 7233-1 that was perfectly suitable for my GA flying. X-Pilot removed that functionality once VATSIM implemented the ICAO FP form. Like all things, I got used to it, but I still liked the old system far better.

Hey guys,

Here’s a screenshot of what it looks like and as seen, even when I go here via a shortcut in the SimBrief UI, the form is part of Vatsim.

So with this said, this isn’t really an issue with SimBrief but rather with the file FP functionality of Vatsim. Luckily, it doesn’t happen very often. Haven’t tried today but yesterday when I saw the issue, it was the second time I had this issue.

I can’t see how it would make a difference if I would fill out the fields on this form manually or if they are automatically populated/imported from SimBrief.

…and now I’m having the same issue again after not having seen it for some time.

I really wonder why this happens. Considering how I do get a message the FP was successfully submitted and how I should enjoy my flight.

Again, this definitely doesn’t feel like the kind of issue you would see on the client side. Meaning I’m quite surprised no one else have confirmed ever seeing the same thing. I guess that might down to the fact how the issue is very intermittent. Meaning most people if having this issue will probably just try again at a later time. When it usually is back to normal.

Now I’ve tried to submit the FP 3 times and received the message it was successful on all 3 occasions and yet I’m told no FP was found on the server when I try to fetch the FP via vPilot. So guess it’s back doing it manually again…sigh…

I often use SimBrief (which sends you to

Are you sure you clicked the “File plan” at the bottom and really received the success message?

I have not had any problems with it. It was available to controllers near instantaneously and showed up in other apps within minutes.

But I wonder why you wanted to fetch it with vPilot. Just to confirm that it is there?

EDIT: only one thing that needs checking: Log in under the same callsign.

Fully positive I received the green success message. I even tried it multiple times.

Reason I fetch the FP in vPilot is to make sure ATC will see my FP. This is how I learned about this issue from start. When I was told by ATC they couldn’t find a FP even when I knew I submitted one.

When I’m able to fetch the FP in vPilot, I know ATC will also see my FP and vice versa.

I always use the same callsign. So connecting using an incorrect callsign isn’t the culprit.

Check, double check, and triple check the flight number / callsign you filed with, and connected with.

But, if you generated this from SimBrief, why is nothing filled in? Looks like a blank template.

Thanks but as for the callsign, I’m positive as already mentioned that isn’t the culprit. Since I never change it but always use the same one.

As for the form not being filled out, I don’t recall exactly from grabbing that screenshot in the first post but here’s another one from the flight today where I’m still enroute and once again, I was told by ATC they were not able to find a flight plan even when I had the message it was successfully submitted via this form.

This is what the top of the form looks like today and it’s all filled out with the data from SimBrief as you can see and as just mentioned, even when I was informed the FP was successfully sent, ATC told me that wasn’t the case. Which I also confirmed by trying to fetch it via vPilot and sure enough, vPilot told me the same thing how no FP could be found on the server.

So once again, I ended up filling out all details manually and after doing that, I used the ‘File flight plan’ button in vPilot and after this, ATC confirmed they now had my FP.

Not really sure why this is happening every now and then but clearly, there’s some issue somewhere when using this FP submit function via the Vatsim website.

Scrap everything I said in my post just above, you guys were fully correct!

I realize this now when I look at my own screenshot I just posted. Where it’s clearly seen how my callsign is just RYR without my flight number attached to it. Really odd why that one has been left out when the FP was transferred from SB to the form but could of course also be I forgot to put it in myself. Will make sure I double-check this going forward and hopefully, this will mean I won’t see this problem again.

Thanks again for pushing me in the right direction :+1:


Awesome, glad you figured it out. I do it all the time lol