I got problem with set up the PTT hotkey in Swift client

Hi guy, as title, I got a problem that I couldnt set up my hotkey button to use as PTT button in swift client.
As detail:
I’m on swift GUI, then open tab Settings>Hotkeys
Click ‘Add’
I clicked on [Select] and ‘Press any key/button…’ appeared
Then the problem came, I couldnt use my keyboard to assign a key, whatever button I press, the box ‘Press any key/button…’ still remains
I’m really depressed :(( plz help me. Many thanks

Hi Long,

are you running swift “as administrator”? Is this in Windows 10?

Have you tried pressing a button on your joystick/yoke to test whether these can be captured by swift?

I forgot to describe the detail, I got swift client on Ubuntu 22.04
I only use keyboard to control the simulator and not get a joystick

Have you followed the installation manual? installation_linux [swift Documentation]

I followed the manual strictly

I’ve tried to setup hotkeys by selecting from the list available below the box, and whenever I press the PTT hotkey combination, there’s a message like above on the log

Hi again,

sorry, I personally have zero experience with Linux. Do you use Discord? If yes, I invite you to join our swift support server (invitation link here) where you’ll find a dedicated support-section for Linux.

I apologize for not being able to help you directly, but I am an ordinary Windows user :see_no_evil:

I accessed Discord and I found the solution to my problem. Thanks to all of your helps!

1 Like

Brilliant, great news!

What was the problem?