FSX CTD since the beginning of May


I have been suffering from an API.dll CTD since the beginning of May. I detailed the crashes here: https://www.avsim.com/forums/topic/635654-fsx-apidll-crash-no-fixes-in-other-threads/?tab=comments#comment-4983809

The CTD primarily occurs when flying on vatsim while connected via vpilot. As one user suggests in the AVSIM post, could there be an issue with the new Microsoft update?

John Dawson noticed that there is a mismatch between my FSX version and the Simconnect version:

  • 31844 Running in “Microsoft Flight Simulator X”, Version: 10.0.61637.0 (SimConnect: 10.0.61259.0)

I tried uninstalling SimConnect but the latest version on the FSX Acceleration SDK is 10.0.61259.0. When I reinstall and start the sim, I still have the same mismatch. Therefore:

  • How do I remove 10.0.61637.0 so that the FSX version matches?
  • Or where do I find/download 10.0.61637.0 to update my SimConnect version

I tried installing from Just Flight and from the Acceleration SDK. I run through the steps to install Acceleration SDK but when i run the SimConnect.msi, it still installs SimConnect 10.0.6129.0. It’s strange because when I run the SimConnect.msi file, the “run as administrator” pop up asks if I would like to install SimConnect 10.0.61637.0 but then when I click “yes”, the installer window appears it says SimConnect 10.0.6129.0. When I check for the version installed it is SimConnect 10.0.6129.0 and FSUIPC is still reporting a mismatch.

The file properties of the Microsoft.FlightSimulator.SimConnect.dll file in "…\Microsoft Flight Simulator X SDK\SDK\Core Utilities Kit\SimConnect SDK\lib\managed"says that it is version “10.0.616.37.0 (FSX-Xpack.20070926-1421)” and yet it does not install this version.

I’m not sure what I’m doing wrong?

  1. embed?resid=12216996670E4BD0!962304&auth Found here: SimConnect Files for FSX/P3D : The Spirit of Flight Simulation
  2. embed?resid=12216996670E4BD0!962305&auth

A complete reinstall of Windows has not fixed the issue. Therefore I’m out of ideas…

It has recently been confirmed that the API.dll crashes (IF no corrupt dll.xml file) are being caused by a Windows update from a few months ago. It’s a shame.

I recommend everyone that is experiencing the issue to submit a support request with Microsoft: https://support.microsoft.com/en-us/home/contact

This will help increase exposure to the issue and will hopefully expedite a hotfix.