Flight Plan not showing

I am using X-Plane 12, the flight plan is loaded to x-pilot, but it doesn’t show on VatSpy

and you are sure you are using the exact same callsign?

Thank you for your response, yes, I am using the exact same callsign. I don’t know if the problem is because I am using X-Plane 12

If you are still having an issue, can you post a screenshot of your VATSIM filed flightplan callsign and also your xPilot callsign after connecting.



Thank you for your interest in helpping me. Yes it is the same callsign

But in VatSpy it says “PV352 No Flight Plan”

A couple more quick questions:

Are you using the latest xPilot release which is version 2 beta 40?

When you file your flight plan on my.vatsim.net, do you receive a “successful” message after clicking File Plan (FPL)? Can you post a screenshot of the top-half of the filed flight plan page after it’s submitted?

Does your flight show correctly on the map.vatsim.net website?

Hi Tim, again I thank you very much for your help. To your questions, yes, I am using version 2.40, VatSpy the latest version. And something has changed, I don’t know what I have done, but today my flight plan is showed in VatSpy. Now it is working correctly.

Thank you again for all your interest in helping me. I wish you a very happy new year, and that all your wishes may come true.

Patricio Valdez


Hi Patricio,

That’s great news, I’m glad you are able to see your flight plans now.

Happy New Year to you as well :slightly_smiling_face:

1 Like

Tell me please, I ran into the same problem, the plan is registered and there is no display of it on the maps, I went into the statistics and there is also no flight plan, what should I do, please help?

Hello Sergey,

Have you read and tried the recommendations from the discussion above? The most common reason for flights not showing is because the flight plan callsign and xPilot callsign do not match. Type the callsign carefully and make sure there are no spaces or hidden characters.

Thank you very much, it’s indeed a typo.

Thanks for the update, Sergey. :slightly_smiling_face: