Filing flightplan via PFPX

For a long time, filing flight plans directly from PFPX to VATSIM is not working due to URL issues. An old solution that worked until now is to replace the URL from:
to: using Chrome plugin but in the last days it’s no longer work and it opens the Vatsim flight plan page without filling anything. What is the fix or the correct URL to get it to work again?

Thank you

I usually file the flightplan via the vpilot client, when logging on to the network having saved the FP in an appropiate format e.g. squawkbox format. Advance filing of FP is not needed.

I found out the easiest and quickest way to file a flightplan is

Hit “Import ICAO Flightplan” on the top right corner, paste your flightplan like

-N0291F240 ROXER

and hit “Process”.
The only thing I have to do after this is to edit “Off Block UTC (HHMM)” as I fly with hours offset in the sim, so I need to adjust this to real time.

Thank you for your answer
I understand what you mean but I don’t like to keep a lot of files for that and then need to delete it. It was so quick and easy to send via PFPX the problem is that they changed the link and I just need the new link to work with again

Thank you for your answer
This is what I doing every flight since it happened.
Before I just hit send in the PFPX and all worked but now they changed the link and it’s not working anymore

Unfortunately, as you are probably aware of, PFPX is no longer under development and is now unsupported be the developers. So a link to the new address can’t be inserted into PFPX.

Of course, as I wrote there is a way to do it with some extension in Chrome it can change the link PFPX sends you and then you can send the flight plan but VATSIM recently changed the URL and it’s no working anymore

Sure, or you could do some simple programming etc, but then I find saving the files as I’ve described much easier and it is not that big a hazzle to delete the directory, when it becomes clogged.

A lot of old things in cert are being removed, as it’s not supposed to be used anymore. It’s very possible that url was caught on the latest “cleanup” efforts, and no one expected that to still be in use.
Current url is this:<ICAO FPL>
This is what tools like Simbrief use, so it’s unlikely to change anytime soon

Thank you for the answer
I tried to replace the URL via Chrome extension the old link with the one that you sent. I moved to the flight plan website but it’s not filling in all the fields as it worked before so strange

If you have an example of the url I can take a closer look. We’ve been doing some updates to the ICAO FPL parser

I tried to work with the Chrome extension to pass the wrong link that PFPX provided and work with the one that you sent.
PFPX send to: (old one)
Your link:

and the example is:

Tell me if I doing something wrong

You didn’t, that’s just not a valid ICAO FPL sent on the url. Looks like the old url did more than just redirect, it changed how the parameters are sent.
myVATSIM expects the part after ?raw= to be a ICAO flight plan format, like the one Reinhard sent above.

If the extension is only capable of replacing the url, I’m afraid that won’t work anymore.

Oh no
This is how it looks before replacing via the extension:

I tried to change manually the start of the URL with the one you gave me but it’s still not working. Looks like I have nothing to do just use the Import ICAO FPL.