EuroScope v3.2.7

heya, good afternoon. I got a quite weird bug at the moment.

For a day of 2 now, I can’t load any sector files in ES without it crashing. It doesn’t give me any crashlog or crash notifications, it just quits.
I used version 3.2.3 and didn’t change a single thing for the past time (except for installing some addons for MSFS, but that should be irrelevant).

I did a complete de-install via the setup program AND manually. I also tried out a different version (3.2.7) which had the same result.

I got a friend of mine to send me his ES folder, once I unzipped it i works fine. But after I close it I can’t start it again without starting from the ZIP file.
Its something within the “Euroscope” folder in program files, because when I leave the “Euroscope” folder located in …/user/roaming as it is, it does work after a reinstall of the other folder.

I unfortinately got no pictures as it is just a instand crash. No warnings, no indications etc.

Steps I follow:

  1. Launch ES.

  2. Select sector file via the file manager popup.

  3. ES crashes once selecting the file.

  4. close the file manager popup

  5. load sector/open via the menu on the top

  6. A empty file launches

I just recently switched over to ES 3.2g and tried the “Shift Change” functionality for the second time now. Both times, the following issues arise:

  • Click “Ready for shiftchange”
  • Select new station, ES hangs a little as it loads the new station config
  • set everything up
  • click on reconnect (target station was not online, switching from EDDV_GND to EDDV_TWR)
  • ES disconects and reconnects after 4 sec
  • ES gets disconnected with a server message “Invalid CID/password”
  • I have to reconnect manually

Is this a known issue where a workaround exists or can this be fixed in future versions?


Had this happen to me aswell today

If one needs to change URL parameters and disconnects the ATIS, sometimes the ATIS won’t connect again due to “wrong CID/password”. This cannot be fixed by reconnecting to the network - which weirdly works and doesn’t result in a “wrong CID/password” message from the server. Connecting ATIS only works again after a restart of EuroScope.

Had the same for some reason, did a fresh install of Windows which actually fixed it (was planning for this anyway, so I didn’t dig much deeper).

What I got is a crash dump indicating an error in MSCTF.dll

Was happening in 3.2.7 (Access via Synology) as well as in 3.2.3 (Access via Synology)

I could also “fix” it by removing most of the settings lines in the .prf, but with the next start (and ES writing lines into the .prf) it crashed again.

1 Like

Hi Gergely,

a small feature request that we can attach the taxi out list to the bottom of the start up list, and the take off list to the bottom of the taxi out list, in the same way we can with the SIL/SEL.


Hi, I would be happy to test your files. Try to pack the profile (be sure to delete your password) and all files referenced from there. I will do a try.

Invalid CID/password happens time to time. I will ensure to get new token from the server for every kind of connect (reconnect, ATIS connnect).

If you have the dumpl files, please send them to me.

They are in the post, those “Access via Synology” links. I’ve shared them via my NAS :slight_smile:

1 Like

any ETA of the new version? :slight_smile:

Two small things I noticed,

  • Previously, I had the ATIS checkbox automatically enabled - but I don’t seem to be able to get it saved anymore
  • Very few times when switching ASRs (from VSMR to non-VSMR though I dont know if that has anything to do with it), the previous VSMR window is displayed on the non-vsmr window. So I see all the aiport text I have enabled on the VSMR and nothing of the ACC view. ES did change windows though, because topsky’s header bar is displayed and the VSMR one was gone.
    One thing I did notice was that zooming in restored the correct view instantly. However, since I have zoom disabled on my ACC view, this is very annoying when it happens.
    In short, sometimes the new display settings are not rerendered (correctly) after switching ASRs, zooming rerenders them correctly.

I am ready with the major updates. They need a bit more testing.
I hope to fix the minor issues this week-end.
So next week/week-end is planned for the next release.

The ASR switch issue is fixed for the next release.
WHat do you mean by ATIS check box? If you refer to the controller list, then I have no problem saving if the ATIS controllers are on/off.

Glad to hear that is fixed!

The atis box I was referring to is this one:
It’s nothing major, but it used to be “checked” on startup for me. But I cannot get it to be saved as such anymore.

1 Like

Do you close the frequency chat by doubleclick?

Until it is fixed in the next release use upper case position IDs. BW should work.

1 Like

Yes, that closes the chat unfortunuately

Correct. Double clicking the frequency chat closes it even when the option to never close freq chat is turned on.

Good day,

I recently discovered an other bug. It looks like stuff that is drawn on the radar screen by a plugin is only triggered by panning or zooming the radar screen.

For example: We have a lot of areas drwn by the Topsky plugin an when an area changes state, in the past it was immideately updated on the screen.
Like an area that goes from active to inactive. In the past this area was disappearing automatically but in this version it’s only disappearing when you pan or zoom the radar window.