EuroScope v3.2.6


Thanks for all the help in testing the v3.2.4. I tried to fix most of the bugs and breaks and I also added some changes to avoid LAGging.

Please try the next release: v3.2.6 – EuroScope



Thank you for the great work!
I just tested this version on sweatbox and all my reported bugs are solved!!

I only found 2 other bugs during the session:

  1. Sometimes (yes, not always, can’t pinpoint when exactly) the coordination sector next to the COPX point in the COPX point menu is wrong. In the exapmle below the coordination point with EXT_CTR is the fix GTQ. So I expect that (EXT_CTR) should only next to the points after GTQ.

  2. Sometimes (yes, not always, can’t pinpoint when exactly) the COPN and NFL remains displayed in the label if the flight is assumed and the track is already in my volume. I expect the XFL and COPX to be displayed as soon as the flight is assumed by me.

Another request is to have more than 4 runways available in a scenario.

Thank you again!


P.S.: In the meanwhile I went online with the version and I had the same problems descripbed above.

Disregard. Problem solved.

Hi! Thank you for the update!
In a future can we expect to get rid of the raster zoomed map?? In extended areas where you have to zoom in and out all the time can get a bit annoying.

Hi again,

A long time request stays open:
Because a lot in EuroScope is trajectory based, can we have a separate AIRCRAFT PERFORMANCE file available so we can add profiles for ATYPs that are not yet in EuroScope? A lot of new types are still not there and the profile of those types is very wrong. It should be great that we can have an offline file like in the real system so the profiles are more accurate.

Another bug that still exists is during Sweatbox that sectors on proxy instances are not displaying the sector. So coordinated flights are not in coordinated color.




Hello there :slight_smile:
Testing the new version i have seen that scrolling/panning has been improved as well as the non-radar-ASRs saving their content again.

However, two things i have noticed until now:

  1. When scrolling, the radar picture gets blurry for a moment before being fully rendered. This is not gamebreaking but a bit of an inconvenience.

  2. Trying to load a GRP ASR seems not willing to load any feature - the screen remains empty. I was able once to load one of the GRP ASRs, but that was the only time it worked and it took quite a while. This is worsened by the fact that trying to open the display settings (or any other dialog for that matter) in that hung stage, it will freeze the entire Scope (the clock is still running, but nothing is clickable, i let it hang for multiple minutes without change to the behaviour), the only way out being closing it via Task Manager. Like as if the display settings were open somehow, but not being displayed. Unloading GRplugin solved this issue however, so it may be plugin-related.

Since we need that plugin for our sector file i will wait for news upon resolution of this bug, either through EuroScope itself or the plugin creator. However, GRP used to work without a problem in 3.2.4, so maybe something could be done… :slight_smile:

Due to the impossibility to get around especially issue #2, i was unable to do further testing, as GRP needs to work for this.

Best regards


Can you link me the plug-in DLL and your ASR file for further testing.


Zooming in thread will be optional from next release.

1 Like

Hello there!

The plugin and ASR in question are all part of this package: LSAS · vACC Switzerland AIRAC Downloads

Hope that serves you.

The ASRs i tested (in LSAS/ASR/) were “5_GRP_LSZB” aswell as “5_GRP_LSZH”, both not working. The plugin in question (in LSAS/Plugins/) is “GRP/GRplugin.dll”

I can make you direct links to only the files if necessary, but thought the AIRAC download is most convenient. Let me know if i can do more. :slight_smile:


I will move the performance to file. That is really needed.
On the other hand I failed to repeat the SweatBox problem. Do you proxy from the client that is running the scenario or from other?

1 Like

Very good new about the performance!!

I indeed proxy from the client that is runnen the scenario. Both Euroscope instances are on the same computer. I use the included FSD server.


Send me your setup (SCT/ESE and scenario file) for testing, please.

Thanks for the promptly update. I can confirm the issues with the GRP plugin. I’ve noticed that the plugin reports some errors while reading the plugin-specific config files. This does only happen with this ES release. Maybe others can confirm they get these messages too?

GRP still shows its custom labels, but no Sectorfile elements. So my best guess would be that something regarding the drawing of Sectorfile elements by plugins and/or an associated function like RefreshMapContent is changed in the latest version. This is also supported by testing another plugin I use during plugin development, which works fine on r34, but cannot be loaded in 3.2.6.

I’ve also noticed that dialog windows are now usually hidden (aka opened in the background, the focus stays with the main ES window). Some Alt-Tab will do the trick to display the dialog window, which otherwise blocks any further inputs on the main window. @1276058 can you check if this might also have been the issue for your point 2? This issue when opening a new dialog window is familiar for me in previous versions, although only when running a playback (connecting a playback usually makes the connect dialog to hide, and I have to switch between windows to bring it back so that I can change the playback speed or pause it). It seems that this has now become a more general issue.

Performance-wise, the CPU load is still quite high, especially also when no connection is established and “nothing goes on” on the screen.

Hi Gergely,

in this version, the panning with right click + drag is affected by the rotation of the ASR.

e.g. display is rotated 180 degrees, the panning controls are inverse.

This wasn’t the behaviour in previous versions.

i can confirm that shift-tabbing showed the dialog for me. i never had this issue before, though :slight_smile:
but after alt+tabbing the settings dialog was indeed shown.

edit: interestingly i just had to press ALT in order for the window to show up, nothing else. what i noticed, when i try to exit euroscope after reproducing this (load GRP ASR → open display settings in menu → press ALT to “unhide” the display settings → click OK on the display settings → click the X to close euroscope and confirm in the dialog), the “Save changes” dialog also appears hidden, and was also shown after pressing ALT+TAB, then ALT successively. After finding that out, EuroScope then exited gracefully.

Also had a few crashes, have sent you the event logs via email Gergely.

It appears it crashed whilst trying to private message an unidentified AC (using Mode C)

Ho do you send a private message to an unidentifed AC?

My Euroscope 3.2.d (havent got the time to use this version), crashes when I want to use it in “middle third”. Others work without issue.

Could we possibly get a middle-half option too? This can be handy for ultra wides.

Please try it with the latest.
I think it the reason could be the message line wrapping problem here too. And that is already fixed.

I think he means a contact me to an unidentified plot