ES 3.2.3 Forcing Mode S Correlation

Hi following the update to 3.2.3, ES seems to force Mode S correlation for those aircraft that have Mode S equipment codes in their flight plan. This is regardless of the C-Mode setting being selected in the general settings.

Could this bug be fixed?

Thanks,
Luke

2 Likes

@904331 please could you take a look at this? v3.2.3 seems to have completely messed up use of C-Mode, as it is overridden with Mode S tags if the flightplan contains Mode S equipment codes. We do not simulate Mode S in the UK so none of our packs/settings are set up for this and it is causing confusion for people

Thanks

If you just uncheck the “Get FP equipments in ICAO format” then ES will ask the servers to send this data in FAA format. Then ES will handle the FAA codes as before v3.2.3.

but not simulating mode S shouldn’t be dependent of what equipment codes ES gets. ICAO format is still the correct format, regardless

We have tested this, and it doesn’t make a difference I’m afraid.

We would like ‘C-mode’ to function as it did before. Using ‘C-mode’ correlation, with Mode A+C tags, etc. To maintain controller pack compatibility we need this or it’s just far too confusing for our controllers.

1 Like

@904331 is it possible to fix this in the next release please?

Since 3.2.3, ‘C-mode’ correlation uses the ‘Uncorrelated/correlated S mode’ tags if the equipment code indicates Mode-S equipped. The Get FP equipments in ICAO format option doesn’t make a difference.

We would like the A+C tags to be used if the correlation mode in General settings is set to ‘C-mode’.

Also, is it possible to rename General settings → Correlation mode → C-mode to A+C-mode? That would make more sense I think!