Cant Connect to Vatsim

I’ve Downloaded 4-5 times with multiple xpilot clients and neither has worked since the update and all my Flights are on Vatsim so I’m Virtually Grounded. Ifirst DL XPilot 2.0.0-beta 35-Windows XP11 and got error invalid version. Dl XPilot 2.0.0 beta-49-Windows with Message I’m running latest version but Connect is greyed out. I’ve Downloaded all the CSL additions . Can Anyone Help me get Started. When I click on Flight Plan it takes me to Vatsim to file a Flight Plan. I have a Navigraph Subscription and Use it. Thanks In Advance for any Help.

Hello Eddie,

The first error you received about an invalid version is because Vatsim requires you to have the current version of xPilot installed in order to connect to the network.

As far as the connect button being greyed out for your beta 49 install, have you taken a look at the xPilot FAQ page regarding this issue?

I’m not sure why you would be grounded, as xPilot is not required software for X-Plane / MSFS. You should still be able to fly your simulator normally.

Hi Tim, Thanks for your Response. My Windows Defender, AVG AntiVirus and Firewall all Have Exclusions to allow XPilot and XPlane. There is an Xpilot entry in XPlanes Plugin Menu. What other Pilot Clients are available for XPlane? I Have 5700 Hrs On Vatsim and all my Flights are flown Online, so If I cant connect with Xpilot I’m essentially Grounded. Sure I can fly around in the simulator but cant Log any flight with my VA. Can VPilot be used with XPlane? Thats what I Have used For the last 10yrs with FSX. Thanks Eddie

vPilot is not compatible with XPlane. You have xPilot and swift as your options.

As to the flight plan question, xPilot does not have its own internal flight plan dialogue. All flight plans for xPilot are filed through the dialogue at myVATSIM.

Thanks Nicholas For your Response. I’ll take a look at the Swift Pilot client and see if it would work for me. Thanks for the info on the XPilot flight Plans. Didint know that. Thanks Eddie

Hi Eddie,

Were you able to try the second FAQ fix by modifying the config.json file to use TCP/IP?

In addition to the antivirus exclusion fix, the TCP/IP fix has also worked for other users.

Hi Tim, Thanks for your Response. Will Look into the config.json file and see if that will work. I got the Swift Client to connect but still a lot of errors with it. Thanks for your Info, Greatly appreciated. Eddie

Hi Tim, I modified the config.json file with Notepad and Saved but XPilot connect is still Greyed out. Eddie