Cannot hear any ATC

I have the latest vPilot and have configured the settings according to the recommendations.

I have loaded a flight into MSFS and switched on the electrics and tuned the radios at a centre where there is active controllers.

After loading MSFS I load vPilot in Administrator mode and connect. Online controllers are displayed and when selecting ATIS I hear it but am unsure whether or not it is accurate (I have Live Weather selected in MSFS).

However, when I switch to an active controller frequency I hear nothing. I do get a crackle occasionally then some text is displayed but no voice.

Should the frequency in the top right of vPilot be blue to reflect a connection or this an older version? Mine stays Grey.

I really want to give this a crack but want to link as an Observer first at a busy centre to listen to the phraseology and process before I take the leap.

I should add that I don’t have a microphone at this point and wonder whether this is the cause of my problems.

Any thoughts?

Sorted. Who would have thought that a microphone, or what the computer thinks is a microphone needs to be attached for vPilot to be active in Observer mode.

Thanks to all for helping with this.

Seems it’s not sorted. Can’t for the life of me see what use a forum is if there is nobody able to help. I’ll just go away and delete Vatsim. WOFT.

Well, it’s awfully hard for people to help when no one, or perhaps nearly no one, has experienced the same problem as you.

Also, it seems most people try to get help on Discord these days. Not too many of us using forums anymore. I do, but I’ve been away on business all week, and have put in nearly 100 work hours. No time at all for hobby stuff. Sorry, but it happens.

I’m not sure going away and deleting VATSIM is really a well-measured reaction to this issue. But whatever floats your boat I suppose.

Yes, the box should be blue. If you have a microphone connected and configured properly, and have power connected to the radios in your aircraft, it should all work. Are you sure there’s power connected to your radios in the sim?

It appears I was under the misapprehension that a microphone wasn’t necessary to simply listen to ATC. I have now installed a microphone and the Voice Server has come to life. I apologise for my frustration getting the better of me. Now all I have to do is work out how to have Sim environmental sounds in the speakers and ATC etc. in the headphones.

Yeah, when the client was developed, it was developed essentially for pilots. And nearly all of our pilots use microphones/headsets. I can’t speak for the developer, but I assume perhaps the thought of people thinking about using vPilot for Observer-only connections either came later, or was/is low priority compared to ease of use for pilots who want to use a microphone/headset.

I know @887155 you’re working other priorities these days, but I wonder if “can use vpilot without a microphone device” is on at least a “maybe in the future” list?

In terms of speaker vs. headset, yep, that’s exactly how I have my own setup configured. Sim to speakers is set up in the sim, and ATC to headset is set up in vPilot settings.

I believe it’s not supported in the AFV code at the moment, so that would need to be updated in order for it to be supported in vPilot or any other pilot client.

I have had the same problem as the OP in the last two days. I can hear voice Atis but not ATC, I am not able to transmit either. I flew a Vatsim flight two days ago and everything was normal, I did nothing to the settings but when I wanted to fly from EGGD to EGHH yesterday morning I found myself with this problem. Later I couldn’t hear voice atis either, but now this morning I can.

It’s quite a weird one imo. What is different between voice atis & atc? :thinking:

I think this VR venture is sent to teach me patience - and I think it’s working! :blush:

I just tried a different non VR (my normal one is a HP reverb) Sennheiser with mic headset. Same thing, I can hear Atis but not ATC in observer mode, but yesterday was in full normal mode.
The green Tx/Rx lights in the top right of vPilot work as normal but I can’t hear anything. I tried quickly pressing the transmit button to see if the Tx light worked - it did.
I didn’t have to choose a new headset in vPilot settings, it appeared to use the Sennheiser automatically?

I think it was AI assistance needing turned off, even though I don’t know how it was even on!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.