Vpilot and with FSX and MSFS - Model Matching


I have an issue with Vpilot and two simulators. My FSX is installed and runs as admin. My MSFS is not installed as admin and does not run as admin. My copy of vpilot that I have always used with FSX I have always run as admin, however it does not find any model matches for MSFS and does not have MSFS listed in settings for this. If I run it as not admin it offers model matches for MSFS but the entries for FSX are then missing. This must be because it is using two different config files to load, their location determined by whether it runs as admin or not admin. I could just run it admin for FSX and run it not admin for MSFS but it must be possible to get Vpilot to recognize FSX and MSFS in the same instance, I am a little confused. Anyone else had this issue?

Probably not much help, but I run FSX as admin and both MSFS and vPilot as not admin and vPilot has no issues with model matching for both sims.

I didn’t do anything special when installing vPilot. It just found both on first start.

Thanks for the reply, It’s interesting to know it your setup works, maybe I should delete or rename all the vPilot files and reinstall totally fresh.

When you run vPilot as admin, do you have to provide credentials for a different account on your system?

No, it’s using the same vpilotconfig.xml but if I start admin it sees FSX and if I start without admin it sees MSFS. If I rename vpilotconfig.xml it complains in both cases. The file includes reference to both FSX and MSFS model matching.

I have to type a user account control admin password.

Where do you have vPilot installed? What folder?

It’s installed to F:/vpilot

So that’s why it uses the same vPilotConfig.xml either way, because you don’t have vPilot installed in a folder that is user-specific, such as the default appdata folder.

My guess is that your MSFS and FSX installations are user-specific, which is why it doesn’t find one or the other depending on which user you are running as (admin or non-admin).

So if I used the default install location and it would find both?

No, if you used the default, then you’d have to separate vPilot configurations, one for the non-admin user and one for the admin user. Each one would still find just one of the sims.

So how did Ernest above manage it? User permissions in windows are always confusing.

It’s confusing because “running vpilot as admin” can mean two different things. You can be logged into windows as an administrator account, and run apps without admin privileges, or run them “as admin” by right clicking and choosing “run as administrator”. You get a confirmation prompt, but you don’t have to enter any credentials because you are already logged in with an administrator account.

The other way is when you are logged in as a non-admin user, and then when you try to run vpilot (or any other app) as an admin, you are prompted to enter the credentials for an administrator user on the same computer. When you do that, the app runs as that other admin user, not as the user you are logged into Windows with. And therefore the location of user-specific folders and files, such as the MSFS configuration files, changes to that other admin user.

So my guess is that Ernest is logged in with an admin user and is NOT having to enter any other credentials when running vPilot as an admin.

I see. I think :-). Thanks for explaining.

Since joining the network, I have had issues with model matching reports, as vPilot encounters other aircraft in the vicinity. It seemed despite installing the .vmr from fsltl on FBW’s installer, this was going to continue. However I had other issues with the failure in the install of the standard model of Airbus A310-300 and the new ATR 4/7 in the MSFS, I submitted a ticket to MSFS to find out why. The fact that i had the minimal set-up to run MSFS, the MS team highlighted a windows error in the file that I submitted, that led me to find that .net 4.7.2 had a problem. I therefore installed .net 4.8.1, but failed to successfully remove 4.7.2. Now when it came to the current issue, I opened vPilot and examined vPilot.exe.config, I found that it referenced .net 4.7.2 in the '<supportedRuntimeversion= ’ line at the position ‘ku=".NETFramwork,Version’. I edited this to read 4.8.1, saved and re-ran vPilot, I haven’t had a problem since. I am uncertain of the reasons as to why .net 4.7.2 has issues, but felt it important enough to make comment here.

Forget everything I said in my last post - It had nothing to do with it, at least there was a small issue but insignificant. I have since found the widget on flightsim.to where one can edit and select the aircraft to appear in a new .vmr file placed inside vpilot’s folder. It can be in addtion to other .vmr files already present.