Child Killed: unknown signal

Hi hi,

I’ve just updated to v2.0.0-beta.48 successfully. When I run the .exe for the first time I get the following error:

After that when I try to run it again nothing happens.

1 Like

This has been reported a few times, but I can’t reproduce it on my end. I have a hunch that it’s video driver related.

Do you have EVGA Precision X1 installed by any chance? One user reported that turning it off allowed them to open xPilot, but your mileage may vary.

The error is caused by obsolete app dependencies from previous versions not getting deleted by the installer, thus causing xPilot to crash when trying to launch it after updating.

The simplest solution is to delete the entire folder where the xPilot client is installed (by default, C:\Program Files\xPilot ), then re-run the latest xPilot installer.

1 Like

Hi Alessandro - did you manage to resolve the issue? I am getting the same error and not sure how to fix. thanks

Hi Ritesh,
Yes, as Justin suggested: I manually removed the entire xPilot client folder and reinstalled it.

This has not worked for me. I’m coming back to VATSIM after the move from XP11 to XP12 and I have completely deleted my XP11 installation and old version of xPilot.

Even with a fresh install I’m getting the same error message trying to start beta.49

1 Like

Justin, I hate to jump into the middle of your post comms but I am having an issue which when after downloading the CSL file (i think this is what it is called) which is needed for xpilot to connect and function, no matter what folder I attempt to save every folder (which I have tried every folder on my computer) and it rejects saying this file can’t be saved in whichever folder. It keeps saying it has to be saved into the xplane folder which I have tried in both xplane 11 and 12 folders and nothing works. See if you can open the included screen shot link? Depending on the file message may alter slightly but it is stating the same reason for not being able to save. So frustrating!!